Reported Incident
Incident Report for Apex Networks Ltd
Resolved
This incident has been resolved.
Posted May 28, 2020 - 14:37 BST
Update
We are continuing to monitor for any further issues.
Posted May 27, 2020 - 17:47 BST
Monitoring
A suspected RMS network issue has now been resolved but we are continuing to monitor
Posted May 27, 2020 - 17:20 BST
Update
We are continuing to investigate this issue.
Posted May 27, 2020 - 16:40 BST
Investigating
We are investigating a possible issue that has been reported to us by a handful of customers
Posted May 27, 2020 - 16:38 BST
This incident affected: Apex RMS.